watchOS 4.3.1 inclut un avertissement concernant la prise en charge des anciennes applications

 

La première version bêta de watchOS 4.3.1 inclut un message avertissant les propriétaires d’Apple Watch que les anciennes applications perdront leur support sur les futures versions du système d’exploitation.

Le message donne également une recommandation aux développeurs de ces applications. « Le développeur de cette application doit la mettre à jour pour améliorer sa compatibilité », indique l’avertissement. Il apparaît lorsque des applications héritées de watchOS 1 sont ouvertes. Malgré ce avertissement, appuyer sur « OK » permettra à l’application de fonctionner normalement, cela suggère que watchOS 4.3.1 supportera encore ces anciennes apps.

Pour rappel, Apple a informé en novembre dernier les développeurs qu’en 2018, elle n’accepterait plus les soumissions d’applications de watchOS 1. Apple leur avait expliqué qu’ils devaient utiliser le SDK watchOS 2 pour mettre à jour les anciennes applications. Et maintenant, les nouvelles applications doivent être construites en utilisant le SD watchOS 4 ou ultérieur.

Bien que l’avertissement ne mentionne pas la date précise de la fin du support des anciennes apps de watchOS 1, il semblerait que cela se produira lors du lancement de watchOS 5. Cette nouvelle mouture sera dévoilée à la WWDC 2018. Il s’agit de la conférence annuelle des développeurs d’Apple qui aura lieu du 4 juin au 8 juin au McEnery Convention Center de San Jose, en Californie.

 
  • 21880 Posts
  • 8482 Comments
Fondateur & Rédacteur
Aucun commentaire pour l’instant! Vous êtes le premier à commenter.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *

Ce site utilise Akismet pour réduire les indésirables. En savoir plus sur comment les données de vos commentaires sont utilisées.